Dieser Artikel bezieht sich auf die Version 4.2.x.x. Wenden Sie den Workaround auf andere Versionen nur nach Rücksprache mit der Upload24 GmbH an.
Symptom
PDF-Dokumente werden nur langsam geöffnet. Der PDF-Viewer des WorkflowPortals reagiert langsam und zeigt die Seiten verzögert an.
Ursache
Die Ursache kann in einem langsamen Client liegen. Aber auch sehr große PDF-Dateien oder gescannte Seiten können die Performance negativ beeinflussen.
Lösung
Das WorkflowPortal kann auch den browsereigenen oder den systemeigenen PDF-Viewer zur Anzeige verwenden. Welcher Viewer verwendet wird, hängt nach diesem Workaround von den Einstellungen des Browsers ab.
- Angehängte ZIP-Datei herunterladen und entpacken
- Ordner "nativeViewerPDF" kopieren nach "#Install#\web\html\www"
- Sicherungskopie der Datei "#Install#\web\html\www\script\task\UsePDFViewer.js" anlegen
- Datei "UsePDFViewer.js" kopieren nach "#Install#\web\html\www\script\task" und alte Version überschreiben
- Es kann erforderlich sein, den Cache des Browsers zu leeren. Ein Neustart des WorkflowPortal-Dienstes ist nicht notwendig.