Symptom

Nach dem Öffnen einer Aufgabe reagiert der Workflow für ca. 90 Sekunden nicht mehr. Das Problem tritt nur auf, wenn eine digital unterschriebene PDF-Datei direkt angezeigt wird.


Das Problem kann in der Regel nachgestellt werden, indem die betroffene PDF-Datei auf den Rechner heruntergeladen und dort ohne WorkflowPortal direkt im Adobe Reader geöffnet wird.


Ursache

Der Adobe Reader wird in der WorkflowPortal-Version 3.x für die Anzeige der PDF-Dateien verwendet. In manchen Fällen dauert die Prüfung einer PDF-Unterschrift sehr lange. In diesem Zeitraum reagiert der Adobe Reader nicht, womit auch der Browser und die Workflow-Anwendung "hängen".


Lösung

Deaktivierung der Unterschriftsprüfung im Adobe Reader